import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{5,12}$)(?=(?:[^a-zA-Z\\u0590-\\u05fe\\n]*[a-zA-Z\\u0590-\\u05fe]){4}[^a-zA-Z\\u0590-\\u05fe\\n]*$)[a-zA-Z\\u0590-\\u05fe]{0,4}[0-9]{3,8}[a-zA-Z\\u0590-\\u05fe]{0,4}$";
final String string = "abcd123efgh\n"
+ "abc123efgh\n"
+ "abc123efg\n"
+ "ab123efg\n"
+ "ab123ef\n"
+ "a123ef\n"
+ "a123e\n"
+ "ab123c\n"
+ "abc123d\n"
+ "123abcd\n"
+ "123e\n"
+ "123e";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}