#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ux)(?<d> [0-9] [-_ –.]* ){4} # subpattern definition" & @CRLF & _
"" & @CRLF & _
"(?= " & @CRLF & _
" \g<d>{4} (?: \g<d> (?: \g<d>{3} )? )? # allowed digit sequences" & @CRLF & _
" (?: \g<d>+ (*SKIP) (*F) )? # skip the substring if digits remain" & @CRLF & _
")" & @CRLF & _
"" & @CRLF & _
"\g<d>* (?= \g<d>{4} ) # backtrack until there're 4 digits at the end"
Local $sString = "valid:" & @CRLF & _
"12345678" & @CRLF & _
"123456789" & @CRLF & _
"123456789012" & @CRLF & _
"123-456789" & @CRLF & _
"123 45 6789" & @CRLF & _
"123 – 45 – 6789" & @CRLF & _
"" & @CRLF & _
"invalid:" & @CRLF & _
"1234567" & @CRLF & _
"1234567890" & @CRLF & _
"12345678901" & @CRLF & _
"1234567890123" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")