import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<d> [0-9] [-_ –.]* ){4} # subpattern definition\n\n"
+ "(?= \n"
+ " \\g<d>{4} (?: \\g<d> (?: \\g<d>{3} )? )? # allowed digit sequences\n"
+ " (?: \\g<d>+ (*SKIP) (*F) )? # skip the substring if digits remain\n"
+ ")\n\n"
+ "\\g<d>* (?= \\g<d>{4} ) # backtrack until there're 4 digits at the end";
final String string = "valid:\n"
+ "12345678\n"
+ "123456789\n"
+ "123456789012\n"
+ "123-456789\n"
+ "123 45 6789\n"
+ "123 – 45 – 6789\n\n"
+ "invalid:\n"
+ "1234567\n"
+ "1234567890\n"
+ "12345678901\n"
+ "1234567890123\n";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}