// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ux)(?<d> [0-9] [-_ –.]* ){4} # subpattern definition
(?=
\g<d>{4} (?: \g<d> (?: \g<d>{3} )? )? # allowed digit sequences
(?: \g<d>+ (*SKIP) (*F) )? # skip the substring if digits remain
)
\g<d>* (?= \g<d>{4} ) # backtrack until there're 4 digits at the end").unwrap();
let string = "valid:
12345678
123456789
123456789012
123-456789
123 45 6789
123 – 45 – 6789
invalid:
1234567
1234567890
12345678901
1234567890123
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}