package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?x)(?<d> [0-9] [-_ –.]* ){4} # subpattern definition
(?=
\g<d>{4} (?: \g<d> (?: \g<d>{3} )? )? # allowed digit sequences
(?: \g<d>+ (*SKIP) (*F) )? # skip the substring if digits remain
)
\g<d>* (?= \g<d>{4} ) # backtrack until there're 4 digits at the end`)
var str = `valid:
12345678
123456789
123456789012
123-456789
123 45 6789
123 – 45 – 6789
invalid:
1234567
1234567890
12345678901
1234567890123
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}