#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?u)(`+)( )*([\p{sc=Hiragana}\p{sc=Katakana}\p{sc=Han}ー~])"
Local $sString = "Markdown の行内コード`code`はバッククォート`` ` ``で囲うことで表現します。" & @CRLF & _
"" & @CRLF & _
"コードブロックは3つの連続したバッククォートで囲います。" & @CRLF & _
"" & @CRLF & _
"```python" & @CRLF & _
"print('Hello World')" & @CRLF & _
"```" & @CRLF & _
"" & @CRLF & _
"行内コードで`日本語`を囲うと、期待しない置換が実行されます。" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "$1 $3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)