# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(`+)( )*([\p{sc=Hiragana}\p{sc=Katakana}\p{sc=Han}ー~])"
test_str = ("Markdown の行内コード`code`はバッククォート`` ` ``で囲うことで表現します。\n\n"
"コードブロックは3つの連続したバッククォートで囲います。\n\n"
"```python\n"
"print('Hello World')\n"
"```\n\n"
"行内コードで`日本語`を囲うと、期待しない置換が実行されます。\n\n")
subst = "$1 $3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.UNICODE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.