use strict;
my $str = 'Markdown の行内コード`code`はバッククォート`` ` ``で囲うことで表現します。
コードブロックは3つの連続したバッククォートで囲います。
```python
print(\'Hello World\')
```
行内コードで`日本語`を囲うと、期待しない置換が実行されます。
';
my $regex = qr/(`+)( )*([\p{sc=Hiragana}\p{sc=Katakana}\p{sc=Han}ー~])/up;
my $subst = '$1 $3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";