// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)(`+)( )*([\p{sc=Hiragana}\p{sc=Katakana}\p{sc=Han}ー~])").unwrap();
let string = "Markdown の行内コード`code`はバッククォート`` ` ``で囲うことで表現します。
コードブロックは3つの連続したバッククォートで囲います。
```python
print('Hello World')
```
行内コードで`日本語`を囲うと、期待しない置換が実行されます。
";
let substitution = "$1 $3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}