import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"(`+)( )*([\p{sc=Hiragana}\p{sc=Katakana}\p{sc=Han}ー~])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Markdown の行内コード`code`はバッククォート`` ` ``で囲うことで表現します。
コードブロックは3つの連続したバッククォートで囲います。
```python
print('Hello World')
```
行内コードで`日本語`を囲うと、期待しない置換が実行されます。
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 $3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)