const regex = /(`+)( )*([\p{sc=Hiragana}\p{sc=Katakana}\p{sc=Han}ー~])/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(`+)( )*([\\p{sc=Hiragana}\\p{sc=Katakana}\\p{sc=Han}ー~])', 'gu')
const str = `Markdown の行内コード\`code\`はバッククォート\`\` \` \`\`で囲うことで表現します。
コードブロックは3つの連続したバッククォートで囲います。
\`\`\`python
print('Hello World')
\`\`\`
行内コードで\`日本語\`を囲うと、期待しない置換が実行されます。
`;
const subst = `$1 $3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);