package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bdatetime-local\b`)
var str = `"datetime" === true. Para a minha expressão ficar correta eu preciso que ele encontre a partir de uma string de char inserida somente as palavras correspondentes a mesma, ou seja, para ser true no caso do "datetime" a palavra inserida precisaria ser "datetime-local`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}