import re
regex = re.compile(r"\bdatetime-local\b", flags=re.MULTILINE)
test_str = "\"datetime\" === true. Para a minha expressão ficar correta eu preciso que ele encontre a partir de uma string de char inserida somente as palavras correspondentes a mesma, ou seja, para ser true no caso do \"datetime\" a palavra inserida precisaria ser \"datetime-local"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")