import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bdatetime-local\\b";
final String string = "\"datetime\" === true. Para a minha expressão ficar correta eu preciso que ele encontre a partir de uma string de char inserida somente as palavras correspondentes a mesma, ou seja, para ser true no caso do \"datetime\" a palavra inserida precisaria ser \"datetime-local";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}