const regex = /\bdatetime-local\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bdatetime-local\\b', 'gm')
const str = `"datetime" === true. Para a minha expressão ficar correta eu preciso que ele encontre a partir de uma string de char inserida somente as palavras correspondentes a mesma, ou seja, para ser true no caso do "datetime" a palavra inserida precisaria ser "datetime-local`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}