// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bdatetime-local\b").unwrap();
let string = "\"datetime\" === true. Para a minha expressão ficar correta eu preciso que ele encontre a partir de uma string de char inserida somente as palavras correspondentes a mesma, ou seja, para ser true no caso do \"datetime\" a palavra inserida precisaria ser \"datetime-local";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}