#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((\/(tests|__tests__)((\/|\/.*\/)[^_][^/]*))|(((\/|\/.*\/)[^_][^/]*)\.(spec|test)))\.[jt]sx?$"
Local $sString = "/tests/hello.ts" & @CRLF & _
"/tests/chop/_hello.jsx" & @CRLF & _
"/tests/yip/_yap/he_llo.jsx" & @CRLF & _
"/tests/hello/world.jsx.hi" & @CRLF & _
"/__tests__/cool.js" & @CRLF & _
"/src/cool/_chop/d_ello.spec.ts" & @CRLF & _
"/src/cool/io/hello.test.ts" & @CRLF & _
"/src/world/_hello.spec.ts" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")