package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((\/(tests|__tests__)((\/|\/.*\/)[^_][^/]*))|(((\/|\/.*\/)[^_][^/]*)\.(spec|test)))\.[jt]sx?$`)
var str = `/tests/hello.ts
/tests/chop/_hello.jsx
/tests/yip/_yap/he_llo.jsx
/tests/hello/world.jsx.hi
/__tests__/cool.js
/src/cool/_chop/d_ello.spec.ts
/src/cool/io/hello.test.ts
/src/world/_hello.spec.ts
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}