re = /((\/(tests|__tests__)((\/|\/.*\/)[^_][^\/]*))|(((\/|\/.*\/)[^_][^\/]*)\.(spec|test)))\.[jt]sx?$/m
str = '/tests/hello.ts
/tests/chop/_hello.jsx
/tests/yip/_yap/he_llo.jsx
/tests/hello/world.jsx.hi
/__tests__/cool.js
/src/cool/_chop/d_ello.spec.ts
/src/cool/io/hello.test.ts
/src/world/_hello.spec.ts
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end