import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\\/(tests|__tests__)((\\/|\\/.*\\/)[^_][^/]*))|(((\\/|\\/.*\\/)[^_][^/]*)\\.(spec|test)))\\.[jt]sx?$";
final String string = "/tests/hello.ts\n"
+ "/tests/chop/_hello.jsx\n"
+ "/tests/yip/_yap/he_llo.jsx\n"
+ "/tests/hello/world.jsx.hi\n"
+ "/__tests__/cool.js\n"
+ "/src/cool/_chop/d_ello.spec.ts\n"
+ "/src/cool/io/hello.test.ts\n"
+ "/src/world/_hello.spec.ts\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}