import re
regex = re.compile(r"((\/(tests|__tests__)((\/|\/.*\/)[^_][^/]*))|(((\/|\/.*\/)[^_][^/]*)\.(spec|test)))\.[jt]sx?$", flags=re.MULTILINE)
test_str = ("/tests/hello.ts\n"
"/tests/chop/_hello.jsx\n"
"/tests/yip/_yap/he_llo.jsx\n"
"/tests/hello/world.jsx.hi\n"
"/__tests__/cool.js\n"
"/src/cool/_chop/d_ello.spec.ts\n"
"/src/cool/io/hello.test.ts\n"
"/src/world/_hello.spec.ts\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")