// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((\/(tests|__tests__)((\/|\/.*\/)[^_][^/]*))|(((\/|\/.*\/)[^_][^/]*)\.(spec|test)))\.[jt]sx?$").unwrap();
let string = "/tests/hello.ts
/tests/chop/_hello.jsx
/tests/yip/_yap/he_llo.jsx
/tests/hello/world.jsx.hi
/__tests__/cool.js
/src/cool/_chop/d_ello.spec.ts
/src/cool/io/hello.test.ts
/src/world/_hello.spec.ts
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}