# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:^| )([a-zA-Z0-9])/$1/gm;t' <<< "This Is A Test
another Test
90 more tests
Some 100 More Tests"