re = /(?:^| )([a-zA-Z0-9])/m
str = 'This Is A Test
another Test
90 more tests
Some 100 More Tests'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result