using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^| )([a-zA-Z0-9])";
string substitution = @"$1";
string input = @"This Is A Test
another Test
90 more tests
Some 100 More Tests";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}