// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:^| )([a-zA-Z0-9])").unwrap();
let string = "This Is A Test
another Test
90 more tests
Some 100 More Tests";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}