use strict;
my $str = 'This Is A Test
another Test
90 more tests
Some 100 More Tests';
my $regex = qr/(?:^| )([a-zA-Z0-9])/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";