#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mx) (?(DEFINE)" & @CRLF & _
" (?<old> old [ ] string ) # (1)" & @CRLF & _
" )" & @CRLF & _
" (?|" & @CRLF & _
" ( > ) # (2)" & @CRLF & _
" (?&old) " & @CRLF & _
" ( < ) # (3)" & @CRLF & _
" | " & @CRLF & _
" ( " ) # (2)" & @CRLF & _
" (?&old) " & @CRLF & _
" ( " ) # (3)" & @CRLF & _
" | " & @CRLF & _
" ( ' ) # (2)" & @CRLF & _
" (?&old) " & @CRLF & _
" ( ' ) # (3)" & @CRLF & _
" | " & @CRLF & _
" ( \( ) # (2)" & @CRLF & _
" (?&old) " & @CRLF & _
" ( \) ) # (3)" & @CRLF & _
" )" & @CRLF & _
""
Local $sString = "(old string) 'old string' old string >old string<" & @CRLF & _
""old string" >old string< old string 'old string'" & @CRLF & _
""
Local $sSubst = "$2new string$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)