const regex = / (?(DEFINE)
(?<old> old [ ] string ) # (1)
)
(?|
( > ) # (2)
(?&old)
( < ) # (3)
|
( " ) # (2)
(?&old)
( " ) # (3)
|
( ' ) # (2)
(?&old)
( ' ) # (3)
|
( \( ) # (2)
(?&old)
( \) ) # (3)
)
/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(' (?(DEFINE)
(?<old> old [ ] string ) # (1)
)
(?|
( > ) # (2)
(?&old)
( < ) # (3)
|
( " ) # (2)
(?&old)
( " ) # (3)
|
( \' ) # (2)
(?&old)
( \' ) # (3)
|
( \\( ) # (2)
(?&old)
( \\) ) # (3)
)
', 'gm')
const str = `(old string) 'old string' old string >old string<
"old string" >old string< old string 'old string'
`;
const subst = `$2new string$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);