import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " (?(DEFINE)\n"
+ " (?<old> old [ ] string ) # (1)\n"
+ " )\n"
+ " (?|\n"
+ " ( > ) # (2)\n"
+ " (?&old) \n"
+ " ( < ) # (3)\n"
+ " | \n"
+ " ( \" ) # (2)\n"
+ " (?&old) \n"
+ " ( \" ) # (3)\n"
+ " | \n"
+ " ( ' ) # (2)\n"
+ " (?&old) \n"
+ " ( ' ) # (3)\n"
+ " | \n"
+ " ( \\( ) # (2)\n"
+ " (?&old) \n"
+ " ( \\) ) # (3)\n"
+ " )\n";
final String string = "(old string) 'old string' old string >old string<\n"
+ "\"old string\" >old string< old string 'old string'\n";
final String subst = "$2new string$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}