import Foundation
let pattern = ##"""
(?(DEFINE)
(?<old> old [ ] string ) # (1)
)
(?|
( > ) # (2)
(?&old)
( < ) # (3)
|
( " ) # (2)
(?&old)
( " ) # (3)
|
( ' ) # (2)
(?&old)
( ' ) # (3)
|
( \( ) # (2)
(?&old)
( \) ) # (3)
)
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
(old string) 'old string' old string >old string<
"old string" >old string< old string 'old string'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2new string$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)