re = / (?(DEFINE)
(?<old> old [ ] string ) # (1)
)
(?|
( > ) # (2)
(?&old)
( < ) # (3)
|
( " ) # (2)
(?&old)
( " ) # (3)
|
( ' ) # (2)
(?&old)
( ' ) # (3)
|
( \( ) # (2)
(?&old)
( \) ) # (3)
)
/mx
str = '(old string) \'old string\' old string >old string<
"old string" >old string< old string \'old string\'
'
subst = '$2new string$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result