# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?(DEFINE)
(?<old> old [ ] string ) # (1)
)
(?|
( > ) # (2)
(?&old)
( < ) # (3)
|
( " ) # (2)
(?&old)
( " ) # (3)
|
( ' ) # (2)
(?&old)
( ' ) # (3)
|
( \( ) # (2)
(?&old)
( \) ) # (3)
)
"""
test_str = ("(old string) 'old string' old string >old string<\n"
"\"old string\" >old string< old string 'old string'\n")
subst = "$2new string$3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.VERBOSE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.