package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m) (?(DEFINE)
(?<old> old [ ] string ) # (1)
)
(?|
( > ) # (2)
(?&old)
( < ) # (3)
|
( " ) # (2)
(?&old)
( " ) # (3)
|
( ' ) # (2)
(?&old)
( ' ) # (3)
|
( \( ) # (2)
(?&old)
( \) ) # (3)
)
`)
var str = `(old string) 'old string' old string >old string<
"old string" >old string< old string 'old string'
`
var substitution = "$2new string$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}