#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[AB]:(?P<routername>[^#]+)#\s*show port\s*(?P<port>\S+)"
Local $sString = "A:C1900_ROUTER1_SR7# " & @CRLF & _
" " & @CRLF & _
" A:C1900_ROUTER1_SR7# echo "<team:script>"" & @CRLF & _
" " & @CRLF & _
" <team:script>" & @CRLF & _
" " & @CRLF & _
" A:C1900_ROUTER1_SR7# /environment no more " & @CRLF & _
" " & @CRLF & _
" A:C1900_ROUTER1_SR7# " & @CRLF & _
" " & @CRLF & _
" A:C1900_ROUTER1_SR7# show port 4/1/4 " & @CRLF & _
"" & @CRLF & _
"A:C1900_ROUTER1_SR7# " & @CRLF & _
" " & @CRLF & _
" A:C1900_ROUTER1_SR7# echo "<team:script>"" & @CRLF & _
" " & @CRLF & _
" <team:script>" & @CRLF & _
" " & @CRLF & _
" A:C1900_ROUTER1_SR7# /environment no more " & @CRLF & _
" " & @CRLF & _
" A:C1900_ROUTER1_SR7# " & @CRLF & _
" " & @CRLF & _
" A:C1900_ROUTER1_SR7# show port 4/1/4 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")