$re = '/[AB]:(?P<routername>[^#]+)#\s*show port\s*(?P<port>\S+)/m';
$str = 'A:C1900_ROUTER1_SR7#
A:C1900_ROUTER1_SR7# echo "<team:script>"
<team:script>
A:C1900_ROUTER1_SR7# /environment no more
A:C1900_ROUTER1_SR7#
A:C1900_ROUTER1_SR7# show port 4/1/4
A:C1900_ROUTER1_SR7#
A:C1900_ROUTER1_SR7# echo "<team:script>"
<team:script>
A:C1900_ROUTER1_SR7# /environment no more
A:C1900_ROUTER1_SR7#
A:C1900_ROUTER1_SR7# show port 4/1/4 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);