# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[AB]:(?P<routername>[^#]+)#\s*show port\s*(?P<port>\S+)"
test_str = ("A:C1900_ROUTER1_SR7# \n"
" \n"
" A:C1900_ROUTER1_SR7# echo \"<team:script>\"\n"
" \n"
" <team:script>\n"
" \n"
" A:C1900_ROUTER1_SR7# /environment no more \n"
" \n"
" A:C1900_ROUTER1_SR7# \n"
" \n"
" A:C1900_ROUTER1_SR7# show port 4/1/4 \n\n"
"A:C1900_ROUTER1_SR7# \n"
" \n"
" A:C1900_ROUTER1_SR7# echo \"<team:script>\"\n"
" \n"
" <team:script>\n"
" \n"
" A:C1900_ROUTER1_SR7# /environment no more \n"
" \n"
" A:C1900_ROUTER1_SR7# \n"
" \n"
" A:C1900_ROUTER1_SR7# show port 4/1/4 ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.