use strict;
my $str = 'A:C1900_ROUTER1_SR7#
A:C1900_ROUTER1_SR7# echo "<team:script>"
<team:script>
A:C1900_ROUTER1_SR7# /environment no more
A:C1900_ROUTER1_SR7#
A:C1900_ROUTER1_SR7# show port 4/1/4
A:C1900_ROUTER1_SR7#
A:C1900_ROUTER1_SR7# echo "<team:script>"
<team:script>
A:C1900_ROUTER1_SR7# /environment no more
A:C1900_ROUTER1_SR7#
A:C1900_ROUTER1_SR7# show port 4/1/4 ';
my $regex = qr/[AB]:(?P<routername>[^#]+)#\s*show port\s*(?P<port>\S+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}