using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[AB]:(?P<routername>[^#]+)#\s*show port\s*(?P<port>\S+)";
string input = @"A:C1900_ROUTER1_SR7#
A:C1900_ROUTER1_SR7# echo ""<team:script>""
<team:script>
A:C1900_ROUTER1_SR7# /environment no more
A:C1900_ROUTER1_SR7#
A:C1900_ROUTER1_SR7# show port 4/1/4
A:C1900_ROUTER1_SR7#
A:C1900_ROUTER1_SR7# echo ""<team:script>""
<team:script>
A:C1900_ROUTER1_SR7# /environment no more
A:C1900_ROUTER1_SR7#
A:C1900_ROUTER1_SR7# show port 4/1/4 ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}