import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[AB]:(?P<routername>[^#]+)#\\s*show port\\s*(?P<port>\\S+)";
final String string = "A:C1900_ROUTER1_SR7# \n"
+ " \n"
+ " A:C1900_ROUTER1_SR7# echo \"<team:script>\"\n"
+ " \n"
+ " <team:script>\n"
+ " \n"
+ " A:C1900_ROUTER1_SR7# /environment no more \n"
+ " \n"
+ " A:C1900_ROUTER1_SR7# \n"
+ " \n"
+ " A:C1900_ROUTER1_SR7# show port 4/1/4 \n\n"
+ "A:C1900_ROUTER1_SR7# \n"
+ " \n"
+ " A:C1900_ROUTER1_SR7# echo \"<team:script>\"\n"
+ " \n"
+ " <team:script>\n"
+ " \n"
+ " A:C1900_ROUTER1_SR7# /environment no more \n"
+ " \n"
+ " A:C1900_ROUTER1_SR7# \n"
+ " \n"
+ " A:C1900_ROUTER1_SR7# show port 4/1/4 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}