// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[AB]:(?P<routername>[^#]+)#\s*show port\s*(?P<port>\S+)").unwrap();
let string = "A:C1900_ROUTER1_SR7#
A:C1900_ROUTER1_SR7# echo \"<team:script>\"
<team:script>
A:C1900_ROUTER1_SR7# /environment no more
A:C1900_ROUTER1_SR7#
A:C1900_ROUTER1_SR7# show port 4/1/4
A:C1900_ROUTER1_SR7#
A:C1900_ROUTER1_SR7# echo \"<team:script>\"
<team:script>
A:C1900_ROUTER1_SR7# /environment no more
A:C1900_ROUTER1_SR7#
A:C1900_ROUTER1_SR7# show port 4/1/4 ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}