#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[a-zA-Z0-9\-?=%]+\.[a-zA-z]{2,}[a-zA-Z0-9_?=\-%/]*"
Local $sString = "Should match:" & @CRLF & _
"Переходи и жми готово https://t.me/InviterCASHbot?start=785698394asd asd" & @CRLF & _
"t.me/johhhn t.me/johhhn" & @CRLF & _
"a.aa/" & @CRLF & _
"a.aa/dsadasd" & @CRLF & _
"vk.co" & @CRLF & _
"asd.xn---1233/---" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Should not match:" & @CRLF & _
"a" & @CRLF & _
"b" & @CRLF & _
"a.a//" & @CRLF & _
"1.555/" & @CRLF & _
"a.551/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")