import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-zA-Z0-9\\-?=%]+\\.[a-zA-z]{2,}[a-zA-Z0-9_?=\\-%/]*";
final String string = "Should match:\n"
+ "Переходи и жми готово https://t.me/InviterCASHbot?start=785698394asd asd\n"
+ "t.me/johhhn t.me/johhhn\n"
+ "a.aa/\n"
+ "a.aa/dsadasd\n"
+ "vk.co\n"
+ "asd.xn---1233/---\n\n\n"
+ "Should not match:\n"
+ "a\n"
+ "b\n"
+ "a.a//\n"
+ "1.555/\n"
+ "a.551/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}