// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[a-zA-Z0-9\-?=%]+\.[a-zA-z]{2,}[a-zA-Z0-9_?=\-%/]*").unwrap();
let string = "Should match:
Переходи и жми готово https://t.me/InviterCASHbot?start=785698394asd asd
t.me/johhhn t.me/johhhn
a.aa/
a.aa/dsadasd
vk.co
asd.xn---1233/---
Should not match:
a
b
a.a//
1.555/
a.551/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}