import Foundation
let pattern = #"[a-zA-Z0-9\-?=%]+\.[a-zA-z]{2,}[a-zA-Z0-9_?=\-%/]*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Should match:
Переходи и жми готово https://t.me/InviterCASHbot?start=785698394asd asd
t.me/johhhn t.me/johhhn
a.aa/
a.aa/dsadasd
vk.co
asd.xn---1233/---
Should not match:
a
b
a.a//
1.555/
a.551/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)