package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-zA-Z0-9\-?=%]+\.[a-zA-z]{2,}[a-zA-Z0-9_?=\-%/]*`)
var str = `Should match:
Переходи и жми готово https://t.me/InviterCASHbot?start=785698394asd asd
t.me/johhhn t.me/johhhn
a.aa/
a.aa/dsadasd
vk.co
asd.xn---1233/---
Should not match:
a
b
a.a//
1.555/
a.551/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}