const regex = new RegExp('[a-zA-Z0-9\\-?=%]+\\.[a-zA-z]{2,}[a-zA-Z0-9_?=\\-%/]*', 'gm')
const str = `Should match:
Переходи и жми готово https://t.me/InviterCASHbot?start=785698394asd asd
t.me/johhhn t.me/johhhn
a.aa/
a.aa/dsadasd
vk.co
asd.xn---1233/---
Should not match:
a
b
a.a//
1.555/
a.551/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}