# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[a-zA-Z0-9\-?=%]+\.[a-zA-z]{2,}[a-zA-Z0-9_?=\-%/]*"
test_str = ("Should match:\n"
"Переходи и жми готово https://t.me/InviterCASHbot?start=785698394asd asd\n"
"t.me/johhhn t.me/johhhn\n"
"a.aa/\n"
"a.aa/dsadasd\n"
"vk.co\n"
"asd.xn---1233/---\n\n\n"
"Should not match:\n"
"a\n"
"b\n"
"a.a//\n"
"1.555/\n"
"a.551/")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.