#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)#EPCDatabase\/EPCdatabase.param\/epc.db.user=.*$"
Local $sString = "# Mandatory parameter" & @CRLF & _
"#EPCDatabase/EPCdatabase.param/epc.db.user=" & @CRLF & _
"# Mandatory parameter" & @CRLF & _
"#EPCDatabase/EPCdatabase.param/epc.db.password=" & @CRLF & _
"# Mandatory parameter"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")