using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#EPCDatabase\/EPCdatabase.param\/epc.db.user=.*$";
string input = @"# Mandatory parameter
#EPCDatabase/EPCdatabase.param/epc.db.user=
# Mandatory parameter
#EPCDatabase/EPCdatabase.param/epc.db.password=
# Mandatory parameter";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}